HuskTowns | Cross-Server Towny Claiming v3.0.2

A simple and elegant proxy-compatible Towny-style protection plugin
requirements_heading.png
HuskTowns requires the following:
  • Minecraft 1.17.1+ Spigot server
  • Java version 17+
A MySQL 8.0+ database is also required for cross-server support.
Buy a license now
$12.49
EULA: Standard EULA
Secure checkout:
Share and earn
Refer this resource and earn a 10% commission.
296 Views
2 Purchases
3 Downloads
Nov 9, 2023 Published
Feb 19, 2024 Updated
Not yet rated
2.8 MB File size
Type
  1. Economy
  2. Protection
  3. World management
Supported software
  1. Spigot
  2. Paper
Supported versions
  1. 1.17
  2. 1.18
  3. 1.19
  4. 1.20
Creator
Recommended for you
A modern, cross-server player data synchronization system
Not yet rated
4 purchases
A clean, cross-server compatible grief prevention plugin
Not yet rated
1 purchase
Prevents your server from crash packet exploits
5.00 star(s) 83 ratings
1,996 purchases
Elite formatting and filtering plugin. Can replace 200+ plugins. High-performance. Folia supported.
5.00 star(s) 102 ratings
1,980 purchases
High Performance | Customizable | Cross-Version | GeyserMC | Folia Support
5.00 star(s) 54 ratings
1,710 purchases
Share and earn
Refer this resource and earn a 10% commission.
296 Views
2 Purchases
3 Downloads
Nov 9, 2023 Published
Feb 19, 2024 Updated
Not yet rated
2.8 MB File size
Type
  1. Economy
  2. Protection
  3. World management
Supported software
  1. Spigot
  2. Paper
Supported versions
  1. 1.17
  2. 1.18
  3. 1.19
  4. 1.20
Creator
Recommended for you
A modern, cross-server player data synchronization system
Not yet rated
4 purchases
A clean, cross-server compatible grief prevention plugin
Not yet rated
1 purchase
Prevents your server from crash packet exploits
5.00 star(s) 83 ratings
1,996 purchases
Elite formatting and filtering plugin. Can replace 200+ plugins. High-performance. Folia supported.
5.00 star(s) 102 ratings
1,980 purchases
High Performance | Customizable | Cross-Version | GeyserMC | Folia Support
5.00 star(s) 54 ratings
1,710 purchases
Top
You need to upgrade!
Our dark style is reserved for our Premium members. Upgrade here.