HuskClaims | Modern Cross-Server Claims v1.1.2

A clean, cross-server compatible grief prevention plugin
requirements_heading.png
HuskClaims requires the following:
  • Minecraft 1.17.1+ Spigot server
  • Java version 17+
A MySQL 8.0+ database is also required for cross-server support.
Buy a license now
$12.49
EULA: Standard EULA
Secure checkout:
Share and earn
Refer this resource and earn a 10% commission.
192 Views
1 Purchases
3 Downloads
Jan 16, 2024 Published
Apr 4, 2024 Updated
Not yet rated
2.6 MB File size
Type
  1. Gameplay
  2. Protection
  3. World
Supported software
  1. Spigot
  2. Paper
Supported versions
  1. 1.17
  2. 1.18
  3. 1.19
  4. 1.20
Creator
Recommended for you
A modern, cross-server player data synchronization system
Not yet rated
6 purchases
A simple and elegant proxy-compatible Towny-style protection plugin
Not yet rated
2 purchases
Prevents your server from crash packet exploits
5.00 star(s) 85 ratings
2,110 purchases
Elite formatting and filtering plugin. Can replace 200+ plugins. High-performance. Folia supported.
5.00 star(s) 103 ratings
2,027 purchases
High Performance | Customizable | Cross-Version | GeyserMC | Folia Support
5.00 star(s) 54 ratings
1,736 purchases
Share and earn
Refer this resource and earn a 10% commission.
192 Views
1 Purchases
3 Downloads
Jan 16, 2024 Published
Apr 4, 2024 Updated
Not yet rated
2.6 MB File size
Type
  1. Gameplay
  2. Protection
  3. World
Supported software
  1. Spigot
  2. Paper
Supported versions
  1. 1.17
  2. 1.18
  3. 1.19
  4. 1.20
Creator
Recommended for you
A modern, cross-server player data synchronization system
Not yet rated
6 purchases
A simple and elegant proxy-compatible Towny-style protection plugin
Not yet rated
2 purchases
Prevents your server from crash packet exploits
5.00 star(s) 85 ratings
2,110 purchases
Elite formatting and filtering plugin. Can replace 200+ plugins. High-performance. Folia supported.
5.00 star(s) 103 ratings
2,027 purchases
High Performance | Customizable | Cross-Version | GeyserMC | Folia Support
5.00 star(s) 54 ratings
1,736 purchases
Top
You need to upgrade!
Our dark style is reserved for our Premium members. Upgrade here.